SP w Piotrowicach
Forum Szkoły Podstawowej nr 3 w Piotrowicach

Logo - Instal'10

Greif - 2009-10-28, 18:59
Temat postu: Instal'10
Etap szkolny - 21.10.2009

Utwórz procedurę AUTO1, wywołanie której spowoduje narysowanie na ekranie kształtu samochodu jak na Rysunku 1. Proporcje samochodu przedstawiono na tle siatki o rozmiarach 50 pkt. (siatka stanowi tylko ułatwienie analizy wymiarów elementów samochodu - nie należy jej definiować)



Z tego co widziałem, nie czytacie dokładnie poleceń, koła miały mieć bok 50, a nie 25. Auto miało mieć wysokość 100 a nie 200, a takie wymiary widziałem jak sprawdzałem prace. Osie kół miały być dokładnie pod "załamaniami" szyb z dachem i maską. Wszystko było punktowane.
No i pamiętać też trzeba o tym nieszczęsnym wzorze na przekątną kwadratu, bez którego tu się nie można było obyć.

Kto zrobi, niech wklei kod między znacznikami CODE.

faja94 - 2009-12-02, 18:18

Kod:
oto skok :x :y
 pod np :x pw 90 np :y lw 90 opu
już

Kod:
oto auto1
 pw 90 np 50 lw 90 np 25 powtórz 3 [pw 90 np 50] pw 90 np 25
 skok 0 50 pw 90 np 12.5 lw 90 np 50 lw 90 np 50 pw 45 np 50 lw 45
 np 100 lw 45 np 50 lw 45 np 50
 lw 90 np 12.5 lw 90 np 25 powtórz 3 [ pw 90 np 50 ] pw 90 np 25
 skok 0 50 pw 90 np 50 lw 90
już

Greif - 2009-12-05, 02:05

Niestety auto niezbyt dobrze narysowane, ma wyglądać tak jak na obrazku, zwróć uwagę gdzie jest oś każdego koła. I przypominam o wzorze na przekątną kwadratu.

Powered by phpBB modified by Przemo © 2003 phpBB Group