SP w Piotrowicach
Forum Szkoły Podstawowej nr 3 w Piotrowicach

MSExcel - Dziennik

Greif - 2007-11-16, 01:03
Temat postu: Dziennik
Witam,

do rozwiązania mamy

Zadanie nr 3

Pobierz arkusz: Dziennik

Wykonaj zawarte tam polecenia, wynikowy plik zapisz jako dziennik_twój_nick.xls i prześlij na adres postmaster@zspg-piotrowice.kei.pl

faja94 - 2007-11-16, 19:15

Jak należy obliczyć ilość ocen każdego stopnia :?:
Greif - 2007-11-16, 19:31

Do zliczania powtórzeń jakiejś wartości w danym zakresie komórek służy funkcja
LICZ.JEŻELI dostępna w funkcjach statystycznych.
Należy podać zakres komórek i liczbę (lub tekst), której wystąpienie ma być zliczane, np.
Kod:
=LICZ.JEŻELI($E5:$S5;6)

Przypominam, że aby prawidłowo wypełnić arkusz NIE WOLNO do każdej komórki wpisywać reguły, tylko wpisać (w odpowiedni sposób) do jednej komórki i skopiować na inne.

Greif - 2007-11-24, 01:42
Temat postu: Podpowiedź
Kod:
=LICZ.JEŻELI($E5:$S5;6)

Podana wyżej formuła, która trzeba wpisać do pierwszej komórki ma tą wadę, że przy kopiowaniu jej na inne komórki trzeba za każdym razem uwzględniać tą wartość "6" (celujący), po prostu trzeba by ją ręcznie zmieniać na "5", "4" itd. w całym poziomym pasku. Potem cały ten pasek skopiować i wkleić do wierszy poniżej.

Dlatego po prawej stronie wypisałem sobie dane pomocnicze, czyli oceny w identycznej kolejności, jak są na etykietach - celująy, bdb itd. Z tych komórek formuła będzie pobierać wartości.



Następnie trzeba ustalić zakres danych, w których będzie wyszukiwana dana wartość, jak widać chodzi o komórki od C5 do P5.

Teraz najważniejsze, trzeba tak zablokować współrzędne, żeby przy kopiowaniu formuły w prawo, zakres się nie przesuwał też w prawo, przykładowo - przeklejając formułę do komórki S5, zakres też "przeskoczy" o jedną komórkę, a nie może tak być.

Dlatego blokujemy tą część współrzędnych, które się zmieniają, czyli w naszym przypadku są to litery. Stawiamy przed daną literą znak dolarka.
Kod:
=LICZ.JEŻELI($C5:$P5;Y5)


Podsumujmy, co nam to dało:
Po wpisaniu powyższej formuły do komórki R5 i skopiowaniu jej w prawo, otrzymamy dobre wyniki, ale co, gdy zechcemy tą komórkę skopiować w dół, na pozostałe komórki?
Excel "zgłupieje", ponieważ gdy będzie chciał pobrać wartość, której ma szukać w danym zakresie, "zobaczy" puste komórki. Dlaczego?

Otóż po skopiowaniu komórki R5 np. o wiersz niżej, zakres wprawdzie będzie dobry, ale ten trzeci adres w formule zmieni się z Y5 na Y6, a tam nie ma żadnej wartości (lub jest np. błędna jak w naszym przypadku, czyli "5"), którą excel mógłby podstawić do wzoru (formuły).

Co należy zrobić? No jak się domyślacie, wstawić dolarek, ale gdzie? No przed tą współrzędną, która się zmienia, a nie powinna, czyli przed cyfrą 5.

Końcowa formuła będzie więc wyglądać tak:
Kod:
=LICZ.JEŻELI($C5:$P5;Y$5)

Wpisujemy ją TYLKO do komórki R5, potem RMB --> Kopiuj, zaznaczamy cały zakres komórek, do których mamy wkleić tą formułę, no i dajemy znowu RMB --> Wklej i sprawa załatwiona.

===
Jako zadanie proszę mi podać formułę, który trzeba wpisać na dole, do komórki C32, żeby po skopiowaniu jej na pozostałe komórki, dostać poprawne wyniki.

Wskazówka:
Zwróćcie uwagę, jak wpisałem dane pomocnicze, czyli cyfry 6-1.

DARO :D - 2007-11-27, 21:03

JAK ZROBIĆ ŻEBY TO DZIAŁAŁO W KOMÓRCE 32 ?? BO PRÓBOWAŁEM ALE COŚ NIE WYCHODZI ;/
Greif - 2007-11-27, 21:47

A ja wróżka, żebym wiedział, coś Ty tam broił przy kompie? Wpiszże tu, co tam pisałeś, bo jak mam inaczej Ci pomóc?

===
Chicqita, w komórce C32 Ty masz coś takiego:
Kod:
=LICZ.JEŻELI($C32:$P32;J32)

Ale skąd wzięłaś takie wartości?

Przecież składnia tej formuły jest taka, że podajemy zakres komórek (czyli u Ciebie od C32 do P32), no i wartość jakiej ma szukać formuła w tym podanym zakresie (czyli daną ocenę). U Ciebie jest J32, a to jest wartość wzięta z kosmosu.... ;-)

Niech tu ktoś napisze adresy komórek, z jakich ma być ten zakres.

===
Linka wpisała takie coś do tej słynnej pierwszej komórki, średnich nie biorę pod uwagę, bo dobrze są zrobione :-)
Kod:
=LICZ.JEŻELI(C5:C29;6)

Taki zapis jest dobrą pozycją wyjściową do modyfikacji, mianowicie, przy kopiowaniu tej komórki potem w dół, które części współrzędnych by się zmieniały?

Oczywiście liczby, więc żeby się nie zmieniały, to trzeba przy nich dać znak dolarka, czyli
Kod:
=LICZ.JEŻELI(C$5:C$29;6)

Wtedy przy kopiowaniu w dół, zakres pozostanie bez zmian.

Niestety przy kopiowaniu w prawo tej komórki, trzeba będzie zmieniać za każdym razem tą trzecią daną w formule, czyli "6". Oczywiście można to zrobić na dwa razy, czyli najpierw skopiować formułę w dół, a potem cały wklejony pionowy pasek skopiować w prawo, no ale robiąc dane pomocnicze, czyli komórki Y5 do Y10, unikamy tego, bo formuła sobie niejako "sama" pobiera te dane, jeśli ją dobrze dolarkami "zblokujemy".

Ostateczna formuła wygląda więc tak:
Cytat:
=LICZ.JEŻELI(C$5:C$29;$Y5)


Rozwiązanie napisane jest w kolorze tła, TAK JAK ROZWIĄZANIE TESTU NR 2. ;-)

Greif - 2009-01-09, 22:57

Faja, dziennik dobrze.

Powered by phpBB modified by Przemo © 2003 phpBB Group